laravel new blog安装为什么会出错?(解析及方法)

2022-05-15 0 921

下面由Laravel教程栏目带大家介绍关于如何解决laravel new blog安装报错的问题,希望对大家有所帮助!

关于 laravel new blog 安装报错问题

具体问题描述:

使用 laravel 命令下载个新的 laravel 包提示:

Your requirements could not be resolved to an installable set of packages.  Problem 1    - Installation request for doctrine/inflector v1.2.0 -> satisfiable by doctrine/inflector[v1.2.0].    - doctrine/inflector v1.2.0 requires php ^7.0 -> your PHP version (5.6.30) does not satisfy that requirement.  Problem 2    - doctrine/inflector v1.2.0 requires php ^7.0 -> your PHP version (5.6.30) does not satisfy that requirement.    - laravel/framework v5.4.30 requires doctrine/inflector ~1.0 -> satisfiable by doctrine/inflector[v1.2.0].    - Installation request for laravel/framework v5.4.30 -> satisfiable by laravel/framework[v5.4.30].Application ready! Build something amazing.

说我 PHP 版本太低了。

但是我用 composer create-project laravel/laravel --prefer-dist blog

安装就没有问题。这两者有什么问题吗?还有如果要解决 laravel 命令报错,是不是只要更换 PHP 版本就可以了?

问题分析:

首先说下问题:

1.很明显,报错原因是因为laravel5.4.30的组件doctrine/inflector1.2.0的需求PHP的版本为:^php7.0。

2.composer create-project laravel/laravel –prefer-dist blog 下载的版本应该不是laravel5.4.30或者检查下composer.json中看下doctrine/inflector版本是否一致吧?

解决方案:换php7即可。

相关推荐:最新的五个Laravel视频教程

收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

【声明:根据2013年1月30日《计算机软件保护条例》2次修订第17条规定: 为了学习和研究软件内含的设计思想和原理,通过安装、显示、传输或者存 储软件等方式使用软件的,可以不经软件著作权人许可,不向其支付报酬! 鉴于此,也希望大家按此说明研究软件!】
本站所有源码尽量保证原汁原味,如有特殊情况会作出声明及标注,网站资源不做任何二次加密(原版加密除外,不影响程序使用的不会做解密处理),方便您更好的学习参考。 在您的能力范围内,为了大环境的良性发展,请尽可能的选择正版资源。如若本站内容侵犯了原著者的合法权益,可联系我们进行处理。

即刻码站__国内靠谱的站长资源下载平台 php教程 laravel new blog安装为什么会出错?(解析及方法) https://www.jike1995.com/36533.html

常见问题
  • 本站所有资源版权均属于原作者所有,这里所提供资源均只能用于参考学习用,请勿直接商用。若由于商用引起版权纠纷,一切责任均由使用
查看详情
  • 最常见的情况是下载不完整: 可对比下载完压缩包的与网盘上的容量,若小于网盘提示的容量则是这个原因。这是浏览器下载的bug,建议用百度
查看详情

相关文章

发表评论
暂无评论
官方客服团队

为您解决烦忧 - 24小时在线 专业服务